+1
Fixed

After upgrading to Unity 2018.3, Ludiq won't build..

Thromshall 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 5

"593 unit options failed to load and were skipped.

Try rebuilding the unit options with 'Tools > Bolt > Build Unit Options' to purge outdated units."

After rebuilding, nothing changes.

Bolt Version:
1.4.0f11
Unity Version:
2018.3
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
BAD, I'M UNSATISFIED

I cannot open Bolt_1_4_1b3_NET4.unitypackage. I am getting the error 

"Copying Temp/Export
Package/.../.../asset to Assets/Ludiq/Assemblies/sqlite3.dll: Access is denied."

Satisfaction mark by Thromshall 2 years ago

I can confirm that Bolt is having some conflicts with Unity 2018.3. I was having issues generating documentation and was getting the following error:

CSC : error CS1617: Invalid option 'latest' for /langversion; must be ISO-1, ISO-2, Default or an integer in range 1 to 6.

Looks like Bolt needs to use MSBuild 15.0 for 2018.3.

Downgrading to 2018.2 resolves the problem as Unity specifies 6 as the langversion.

Working on Fix

Yup, I started doing that fix for Bolt 2, but I'll be backporting it to v.1.4.1 along with version checking.

Pending Review

Hi Thromshall,

Are you getting compilation errors that prevent you from running Bolt?

Or are these errors only when you try to generate the documentation?

Can you also paste the full stack trace of the "units failed to load" warning?

Fixed in Beta

So I fixed the documentation build errors with MSBuild 14.0 for v.1.4.1b3. Bolt will now properly use MSBuild 15.0 in Unity 2018.3 or above.

I tried a fresh install of Unity 2018.3.0f2 with Bolt 1.4.1b2 and after rebuilding the unit options from "Tools > Bolt > Build Unit Options", the warning disappears. The outdated units were related to Unity classes that got deprecated, in my case. 

Feel free to reopen this thread if you are still getting issues after v.1.4.1b3!