0
Answered

Cant view variables

NeedsLoomis 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 3

On new and old projects (Unity 5.6.2f1 x64) all of my "Variables" components, as well as the Variables window show the error "Error Drawing VariableDeclarationsInspector"


The console spits out 

TypeLoadException: Could not load type 'UnityEngine.ImageConversion' from assembly 'Ludiq.Core.Editor'.
Ludiq.ReorderableList.Internal.ReorderableListResources..cctor () (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/ReorderableList/Internal/ReorderableListResources.cs:40)
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for Ludiq.ReorderableList.Internal.ReorderableListResources
Ludiq.ReorderableList.ReorderableListStyles..cctor () (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/ReorderableList/ReorderableListStyles.cs:22)
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for Ludiq.ReorderableList.ReorderableListStyles
Ludiq.ReorderableList.ReorderableListControl..ctor () (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/ReorderableList/ReorderableListControl.cs:614)
Ludiq.ReorderableList.ReorderableListGUI..cctor () (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/ReorderableList/ReorderableListGUI.cs:17)
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for Ludiq.ReorderableList.ReorderableListGUI
Ludiq.MetadataCollectionAdaptor.GetHeight (Single width, UnityEngine.GUIContent label) (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/MetadataCollectionAdaptor.cs:106)
Bolt.VariableDeclarationsInspector.GetHeight (Single width, UnityEngine.GUIContent label) (at C:/Users/Lazlo/Projects/Ludiq/Bolt.Flow/Editor/Variables/VariableDeclarationsInspector.cs:52)
Ludiq.Inspector.GetCachedHeight (Single width, UnityEngine.GUIContent label, Ludiq.Inspector parentInspector) (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/Inspector.cs:159)
UnityEngine.Debug:LogException(Exception)
Ludiq.Inspector:Draw(Rect, GUIContent) (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/Inspector.cs:117)
Ludiq.LudiqGUI:Inspector(Metadata, Rect, GUIContent) (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/LudiqGUI.cs:53)
Bolt.VariablesEditor:OnGUI(Rect, GUIContent) (at C:/Users/Lazlo/Projects/Ludiq/Bolt.Flow/Editor/Variables/VariablesEditor.cs:20)
Ludiq.Inspector:Draw(Rect, GUIContent) (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/Inspector.cs:70)
Ludiq.Inspector:FieldLayout(GUIContent, Single, RectOffset) (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/Inspector.cs:253)
Ludiq.Individual:OnGUI() (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/Root/LudiqRootObjectEditor.cs:53)
Ludiq.OptimizedEditor`1:OnInspectorGUI() (at C:/Users/Lazlo/Projects/Ludiq/Ludiq.Core/Editor/Inspection/OptimizedEditor.cs:31)
UnityEditor.DockArea:OnGUI()
Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi,

Bolt requires Unity 2017.1 or higher, as stated on the asset store page.

Does this issue persist even if you update Unity?

Regards,

Lazlo

Yeap, did the trick, thanks!