0
Cannot Reproduce

Scene loading troubles on Android

Edd 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 2

Hey everyone !

I've meet some trouble using async scene loading on Android. I trying to load next scene while i'm showing to user a popup. Each next scene is apartly a "clone" of previous scene (it contains camera, the same variables and some same prefabs)

I've made this graph



Scene activation is set on button press.

And for some reason after some while (i can't get, is it happening randomly or not) i get some bug on Android (scene stop working correctly).
And i get this error : InvalidOperationException: Missing target object for 'UnityEngine.Material.SetFloat'. 

I tried to catch it but still can't to figure out where it come from and fix somehow.
And I can't understand is the problem on my side, or something with Bolt

Bolt Version:
1.4.0f7
Unity Version:
2018.2.11f1
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hey Edd,

Sorry you're having this issue.

The graph you showed includes no node for Material.SetFloat. Can you show me the graph where this node is contained?

Also, can you try reproducing the issue on a small project that contains the smallest possible graph that causes the error?

Cannot Reproduce

Hi Edd,

Closing this thread for now as there are no reproduction steps. Things to verify:

This seems like it could be related to this other issue, but it's hard to tell without the right graph screenshot.