0
Answered

Installation problems Bolt 2

kicktherabbit 2 years ago updated by SHRAVAN ELLURU 2 years ago 2

I would like to test the Bolt 2. But after installing I get lots of (37) this errors: 

"Assets/Ludiq/Ludiq.Core/Runtime/Collections/Bictionary.cs(81,42): error CS1644: Feature `out variable declaration' cannot be used because it is not part of the C# 6.0 language specification."

First I tried with .NET 3.5 ... there were more errors (over 300). But same "cannot be used because it is not part of the C# 4.0 language spec" thing ... just with C#4.0

Bolt Version:
2.0.0a1
Unity Version:
2018.2.17f1
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2
GOOD, I'M SATISFIED

Ooops ... ah. sorry. Ok. Thx. 

Satisfaction mark by kicktherabbit 2 years ago
Answered

Hi Kicktherabbit,

As indicated on the download page:

  1. Bolt 2 requires 2018.3 or above
  2. You must make sure to make your .NET API compatibility level to .NET 4.x in your project settings. 
when are you guys going to release bolt v2 officially .im eagerly waiting for this product