0
Under Review

Multiple undos can cause graphs to disappear until Unity restart

V M 3 weeks ago • updated 6 days ago 16 1 duplicate

Some adventures I had today. All in one long day of messing around with Bolt. [I'm a new user].

  1. I Ctrl+Z to undo and most of my Macro disappears. Almost nothing left behind. I click away and back, nothing, I restart Unity.. all back to normal.
  2. Same thing again, Ctrl+Z to Undo. A bunch of nodes disappear.. I undo again.. even more nodes disappear. Mayhem left behind. I click away, back, I redrag and drop the superunit, I delete it and redrag n drop, I reframe the graph, I restart Unity.. nothing. I didn't try to Ctrl Y.. immediately after Ctrl Z. Anyway, unacceptable catastrophic failure.
  3. One of my graph variables disappears. I'm recreating it. It disappears again. I'm recreating it.. it stays this time. Good job you graph variable you..

All in a day of work.

I have Win 10 x64, and Bolt installed without errors, but I do get some yellow warnings after each Unity boot: Ludiq.DictionaryAsset and Ludiq.VariablesAsset failed.

Night night now..

Bolt Version:
1.4.0f11
Unity Version:
2018.2.15f1 Personal
.NET Version:
.3 I think, the one recommended
BAD, I'M UNSATISFIED

I've no idea how to submit a file to you, there's no private message under any Search bar. And I'm very disappointed that you dismiss project-breaking bugs. I had these 2 major issues in just 1 day of testing Bolt. All the testing you refuse to do is a risk, and possibly a lot of wasted time for users. We start working on a Bolt project.. just to discover somewhere mid-production that all sorts of objects are missing and broken, so on.

Satisfaction mark by V M 1 week ago

Duplicates 1

Tried to reproduce it, but without success. :-\

Under Review

Hi Kicktherabbit,

I'm so sorry you had an issue that resulted in lost work. I hope you had a recent backup available.

Actually our programmer Andy also experienced this issue once, but didn't isolate it either.

Can you try to run me through what you were doing before undoing?

Did you get any error or warning in the console?

Does redoing (Ctrl+Y) restore the lost elements?

Nope. Sorry ... I was so irritated, that my first action was another few undos, because I thought maybe I did a strange key combination, where I deleted the stuff. And the next impuls was to close and reload, and hoping that its back. ;-)

And, no ... hadn't a copy, but I was able to reconstruct it quite fast, because I hat some older versions and superunits with parts of it. No prob. 

But I realy tried to reproduce it without result. Don't know what was the point, and why it happend. Always difficult, if a problem just apears so infrequently. 

Next time I will analyse it better ;-) ...

Under Review

Hi V M,

Sorry you're getting this issue. The report was not ignored, it's just that we haven't been able to reproduce it, so we can't attempt a fix. 

Can you create a simple, small project with instructions on how to reproduce the bug from it?

It's possible this happens only on a few people's machines, because of local settings.. If that is true, maybe you can't replicate. But both issues I've encountered and mentioned here are project-breaking bugs, meaning I can't use Bolt at all unfortunately. I'm not sure if helps, but I can send you my tests project where the bugs have happened [in one of the macros, probably one that either looks broken, or empty, but I'm not using Bolt anymore so no idea which one..]. I have no idea how to use github. Do you have a contact email? I can use Wetransfer.
I'm thinking of keeping Bolt for now, and trying Unity again in a few years. Maybe they come to their senses with that dreadful Logo.. And I hope you can afford to test the product more thoroughly meanwhile, and make it more solid and user friendly. I mean more like Unreal BPs. In BPs when you create a variable, the next one you create doesn't return to some default. You can keep creating tons of floats really fast. Populating long lists manually is not fun in Bolt. There are a lot of missing value transfers [float-to-string and such..]. There are no split pins.. so on. There are many quality of life differences that make Unreal BPs much easier to use and faster to set up.
Cannot Reproduce

Hi VM,

Unfortunately if we can't replicate an issue, we can't even begin fixing it. This is why bug reporting always asks for reproduction steps. Test projects are helpful, if the projects are small and lead to a clear reproduction. You can send them via our private message function (right below the search bar).

I'll be closing this topic as it includes 3 separate issues that were reported elsewhere:

  1. Undo bug: See the thread you linked
  2. Variable disappearing: See the FAQ
  3. VariablesAsset warning: See Known Issues (fixed in Unity 2018.2.18)

Thank you for your workflow suggestions. We're addressing all of the variables workflow issues in a big redesign planned for Bolt 2. Creating common variables will be a 1-click operation (see our mockup), on the left sidebar. I did not know about split pins, we'll look into it!

You also dismissed the other one with a Cannot Reproduce. And we're talking about a major bug that can destroy hours, if not days of work, for someone who doesn't backup their stuff very often.

Also, the undo bug is not about variables resetting to Null. But about a variable I'm using simply disappearing and therefore breaking the Macro.

I can't believe you simply dismiss catastrophic failures like these. Just because you cannot reproduce this now it doesn't mean you should close the case and forget about it. These bugs are not imaginary, and they're still there.

Hi VM,

I can assure you we take any bug that incurs data loss very seriously. In fact, they take priority over any other feature development or bug fix. 

However, if we can't reproduce them, we can't fix them. The context you gave me for the bug is vague; it implies a big project and a lot of successive operations, without any error message, example file, screenshot, log, or reproduction steps. I wouldn't even know where to start to get the issue you experienced.

The link for the private message is right under the forum search bar:

Or you can send us a message at support@ludiq.io.

Or you can upload your project publicly, as long as you have all the rights to redistribute its content and remove the Ludiq folder from your zip before uploading.

I will gladly examine this issue as soon as I can get started.

V M via email 6 days ago
Yes the content I gave you is vague indeed, sorry about that. I don't have Unity installed anymore, just this very small, simple project.
I'm transferring it to you via WeTransfer. You should get another email containing the download link, but here it is again:
SNIPPED
I tried to create some modular character, so look inside the 2D platformer character.
There should be only a few macros in this project, and I think one of them is either empty.. or has an entry node.
That's the macro that got corrupted or something, and instead of a bunch of nodes it has either a few or 1 or none.. I don't remember exactly.
Sorry I can't do more. Hope it helps and good luck!
VM

Hi VM, I downloaded the project, thank you. 

However, please remove your upload from WeTransfer, as it includes all the Bolt assets publicly because they were not removed before uploading. This is in fact redistributing Bolt online illegally.

Oh, I'm very sorry. I don't think I can remove those files myself, but you are the only recipient of this transfer, and the files are going to be deleted automatically in 7 days. In the future think of providing a solution for uploads. The mistake I made is very simple to make, I simply sent you the whole project, I don't even know or care what's inside that zip file anymore, because I'm not using Unity atm. If this issue is important to you, think of allowing users to upload stuff somewhere on a server where only you can have access to files. I'm just trying to help anyway, not to do illegal things. : ] Good luck, and thanks for reconsidering the bug!