0
Fixed

NotImplementedException in generated C# for Once unit

Lazlo Bonin (Lead Developer) 2 years ago updated 2 years ago 1
NotImplementedException: The method or operation is not implemented.
Bolt.OnceGenerator.GenerateControlInputSuccessor (Bolt.FlowMethodGenerationContext context, Bolt.ControlInput controlInput) (at Assets/Ludiq/Bolt.Flow/Editor/Framework/Control/OnceGenerator.cs:64)
Bolt.UnitGeneratorUtility+<generatestatements>d__0.MoveNext () (at Assets/Ludiq/Bolt.Flow/Editor/Units/UnitGeneratorUtility.cs:37)
Bolt.SequenceGenerator+<generatecontrolinputbody>d__1.MoveNext () (at Assets/Ludiq/Bolt.Flow/Editor/Framework/Control/SequenceGenerator.cs:21)
Ludiq.GraphGeneratorUtility+<bind>d__3`1[TElement].MoveNext () (at Assets/Ludiq/Ludiq.Graphs/Editor/Generation/GraphGenerationUtility.cs:39)
Bolt.UnitGeneratorUtility+<generatestatements>d__0.MoveNext () (at Assets/Ludiq/Bolt.Flow/Editor/Units/UnitGeneratorUtility.cs:32)
Bolt.UnitGeneratorUtility+<generatescopedstatements>d__1.MoveNext () (at Assets/Ludiq/Bolt.Flow/Editor/Units/UnitGeneratorUtility.cs:50)
System.Collections.Generic.List`1[T]..ctor (System.Collections.Generic.IEnumerable`1[T] collection) (at <ac823e2bb42b41bda67924a45a0173c3>:0)
System.Linq.Enumerable.ToList[TSource] (System.Collections.Generic.IEnumerable`1[T] source) (at <1b13ba6391c74847bbc3eddc86df7eee>:0)
Bolt.BranchGenerator+<generatecontrolinputbody>d__1.MoveNext () (at Assets/Ludiq/Bolt.Flow/Editor/Framework/Control/BranchGenerator.cs:20)
Ludiq.GraphGeneratorUtility+<bind>d__3`1[TElement].MoveNext () (at Assets/Ludiq/Ludiq.Graphs/Editor/Generation/GraphGenerationUtility.cs:39)
Bolt.UnitGeneratorUtility+<generatestatements>d__0.MoveNext () (at Assets/Ludiq/Bolt.Flow/Editor/Units/UnitGeneratorUtility.cs:32)
Bolt.UnitGenerato...</generatestatements></bind></generatecontrolinputbody></ac823e2bb42b41bda67924a45a0173c3></generatescopedstatements></generatestatements></bind></generatecontrolinputbody></generatestatements>
Bolt Version:
2.0.0a1
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Bolt 2