0
Fixed

No root file found

Brent 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 10

I'm getting a non-invasive error at start when I run play in Unity, with the error,

"FileNotFoundException: No root file found ('Ludiq.root')"

About a month ago I was trying to find a way to save data between scenes, saw Bolt had a tool that allowed to save variables across the application, and it seems to have had a negative effect on my project ever since and am now just trying to figure this out.

I have updated build units, deleted all saved PlayerPrefs from the Tools menu, deleted all Project Settings from the Tools menu, then finally deleted and then reinstalled Bolt, but it is still misbehaving.

Has anyone tackled this issue or know how to fix? The only thing that seems to work is starting a brand new project.

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi Brent,

Sorry you're having this issue. Am I right in assuming you're using the latest hotfix (v.1.4.0f10)?

If so that might be a small oversight from me. 

Can you try creating an empty file called Ludiq.root under the Assets/Ludiq/Ludiq folder? You might also need one called Bolt.root under Assets/Ludiq/Bolt.

Let me know if that fixes the issue!

Re-reading your post, I don't understand how this could happen.

Could you paste the full stack trace of the error?

Thanks for the quick reply, I didn't get around to this yesterday, but here is the full error as it appears in the console window:

FileNotFoundException: No root file found ('Ludiq.root'). Cannot determine root path.
Ludiq.PathUtility.GetRootPath (System.String rootFileName, System.String defaultRootFilePath) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Interface/Icons/Icons.cs:610)
Ludiq.Product.get_rootPath () (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Utilities/IconExportUtility.cs:91)
Ludiq.Product.get_resourcesBundlePath () (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Utilities/SearchResult.cs:11)
Ludiq.Product.Initialize () (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Utilities/ScriptReferenceResolver.cs:31)
Ludiq.LudiqProduct.Initialize ()
Ludiq.ProductContainer.Initialize () (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Utilities/SearchUtility.cs:193)
Rethrow as Exception: Failed to initialize product 'Ludiq'.
UnityEngine.Debug:LogException(Exception)
Ludiq.ProductContainer:Initialize() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Utilities/SearchUtility.cs:193)
Ludiq.PluginContainer:Initialize() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/SQLite/SQLite.cs:1004)
Ludiq.PluginContainer:.cctor() (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/SQLite/SQLite.cs:857)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()

Ok, I'll look into fixing that for f11. But in the mean time, the workaround I suggested should work!

Thanks again for the quick reply, I'll try to create those files and see if that at least clears the error. 

If I create that file, will it also clear the data that has been persisting? I haven't determined if the data is persisting because of Bolt, but I can only imagine it has something to do with the application saved data variable I was playing with a month ago; as I stated I have cleared everything that I logically assume would clear this type of data through the tools menu and am not using any other serialization tools that would cause the data persistence.

Disregard that last paragraph of the last comment; I hadn't checked the persistency issue in a couple weeks and we seemed to have resolved that, sorry if that caused any confusion.

Working on Fix

Ok, no problem! Did creating the file fix the issue?

Yes it did, thanks!

Fixed in Next Version

Hi Brent!

Looked into that further. Not sure what happened with the f10 release, but Ludiq.root will definitely be included in f11.