+1
Unity Bug

Flickering / not fully visible texts on units

serialkamikaze 9 months ago • updated by Crystalius 8 months ago 14 1 duplicate

Not sure if it is already posted in some other bug, but this have been bothering quite a while. It is not a big issue, but annoying.

When moving on the flow, texts of the units are flickering and text are not fully visible from time to time. This happens while on full zoom, 1x.

"Workaround"

But I just found that if I move the zoom in slider just a little to decrease the value, they seems to be no longer flickering or missing text. Of course they are a slight smaller in size, but without that annoyance.

  • Using Bolt v1.4.0f6
  • .NET 3
  • Unity 2018.2.8f1
  • macOS High Sierra 10.13.6


Bolt Version:
Unity Version:
.NET Version:

Duplicates 1

Unity Bug

Hi Serialkamikaze!

This is a known issue: https://ludiq.io/bolt/known-issues#calcsize

In some Unity and Bolt version combinations, the header text in nodes might be either cropped or overly spaced out.
This is caused by a Unity bug that was fixed in version 2018.2.3f1. From the changelog:

(1047812) - Editor - Fixed issue where Unity did not calculate GUI text width correctly when GUIStyle used Word Wrap.
Simply update your Unity and the issue will be fixed.


Working on Fix

Oh wait, I see now you're reporting it happens in 2018.2.8f1. Ugh. I guess Unity re-introduced the regression. I'll have to test and get back to you, maybe report it to them again.

I also have the same bug with Unity 2018.2.8f1.

Cannot Reproduce

I can't reproduce the issue here on Unity 2018.2.8f1. Are you on OSX as well?

Working on Fix

Ok, so internally we've apparently been experiencing this as well.

Are you all using non-standard DPI screens?

My screen

DPI: 218
Diagonal: 27"
Resolution: 5120x2880

Getting this too on Unity 2.9. 

My monitor is 4k, 28"

Don't know where to look for DPI

+1

Hi Crystallius and Serialkamikaze!

Could either of you submit a bug report to Unity about the issue? Simply include a project with the latest Bolt version and a simple graph with nodes that fail to render properly.

Do mention in the report that it is a regression from this issue: https://issuetracker.unity3d.com/issues/high-dpi-gui-text-width-not-calculated-correctly-when-guistyle-uses-word-wrap

Thanks in advance!

I am troubled with the same phenomenon (ZOOM 1x).

Unity2018.2.12f1 + Bolt 1.4.0f7

Windows10

4K monitor(3840x2160) 150% scale

+2

I've reported it to Unity and they confirmed it. Got a reply that this bug have been sent to developers for resolution.

Great!

Thank you! Let me know if you have a trackable report.

Unity Bug

Hi Crystallius, any news from Unity?

Hi! 

When I try to check the status of the bug I get server error. I could send you email of the person I was talking to on Discord if you like 

Under Review

Hi David,

Unfortunately this is a know issue in recent Unity versions that is out of our control.

It's been reported before (I'm merging this thread) and is being actively looked at by the Unity developers, see the bug report here: https://issuetracker.unity3d.com/issues/bolt-gui-text-width-is-not-calculated-correctly-when-moving-from-one-resolution-to-another-and-guistyle-uses-word-wrap