0
Cannot Reproduce

Bolt corrupted somehow?

SamWelker 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 2

I've searched for other errors and cannot find any yet.


I've had a constant issue where bolt no longer opens. Reinstalling it, restarting unity, making a brand new project and adding my assets to it, none of these fixed it sadly though the last one did fix it for a short period of time before the issue returned.

The error I am getting is: ArgumentNullException: Value cannot be null.


Basically if a bolt window or setup is open I get that error.

This isn't the entire log entry but about half of it: 

ArgumentNullException: Value cannot be null.
Parameter name: resources
Ludiq.EnsureThat.IsNotNull[IResourceProvider] (IResourceProvider value) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Runtime/Ensure/EnsureThat.Objects.cs:29)
Ludiq.EditorTexture.Load (IResourceProvider resources, System.String path, Ludiq.TextureResolution[] resolutions, CreateTextureOptions options, Boolean required) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Windows/SinglePageWindow.cs:41)
Ludiq.PluginResources.LoadIcon (System.String path, Boolean required) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/SQLite/SQLite.cs:57)
Ludiq.LanguageIconSet.LoadAccessibility (System.String name, Boolean required) (at C:/Users/lazlo/Projects/Ludiq/Ludiq.Core/Editor/Dependencies/ReorderableList/GenericListAdaptor.cs:71)...


Any suggestions or tips to resolve this issue?


I'm in Unity 2018.2 though the issue was the same in 2017.2, 2017.4, and 2018.1.

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
Pending Review

Hi Sam, sorry you're getting this issue.

It's odd, it's as if the resource provider itself was failing to load. Do you get any other console warning or error? Do you have any steps to reproduce this bug from a blank project?

Cannot Reproduce

Marking as cannot reproduce for now. Please comment again if you have reproduction steps!