0
Not a Bug

2018.2.2 and bolt 1.4.0f5 does not seem to work

odyssey96 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 3

1. Download the 4.x package

2.  Create new project targeting .net 4.

3.  Import bolt package - states obsolete apis need upgrading so i do.  Bolt wizard appears and run trough this fine.  No bolt components visible in unity component menu

4.  Save and close project, re-open and bolt wizard appears again.  This happens all the time?

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

thats f1 for the unity release sorry

ok realised what had happened - imported package into unity before net target was changed to 4.  the above issues happen, shutdown unity deleted the whole ludiq folder and then re-opened unity and then re-imported package.

Not a Bug

Hi Odyssey, glad you figured it out.

Indeed, you need to have a project that targets .NET 4.x before Bolt for .NET 4.x. Importing a 3.x version of the plugin in a 4.x project is not supported and is likely to cause many errors.