+1
Unity Bug

Node text scaling or cropping between Unity 2018.1.x and 2018.2.2

Crystalius 1 year ago updated by Lazlo Bonin (Lead Developer) 1 year ago 10 4 duplicates

Hi!

Moved to 1.4 and Unity 2018.2. Very happy about 4k monitor support from Unity (at last! :D)

But Bolt's nodes acts strangely sometimes:


.NET 3.5

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
GOOD, I'M SATISFIED
Satisfaction mark by Crystalius 1 year ago

Duplicates 4

+1
Working on Fix

This seems to be an issue on HDPI displays only, I'll investigate!

+1
Pending Review

Hi Sommer! I need some more information to be able to help:

  • Does this happen at all zoom levels?
  • Are you using a High-DPI display? 
  • Are you on Mac or Windows?
  • Which Unity version are you using?
  • Which Bolt version are you using?

I'm using Windows, Bolt 1.3, And The latest official release from Unity. The Text only glitches out at a certain zoom, (I'll send it tomorrow) But it stays blurry no matter what you do. Keep up The great work and interaction with the community. Your addon is fantastic, the community is great and you/the developers are, too. I hope that is all The information you need. Thanks for replying!

My Dpi scaling is set to a 100% if thats what you mean by high dpi display..

Working on Fix

I saw this issue occur, but I'm not exactly sure what's causing it yet. I think Unity changed some internal measurement code in 2018. Are you using a high DPI screen?

Nope, standard 1920x1080 "hd" screen.I assumed it had something to do with the snapping as I had recently turned it on, and that's when the re-sizing started to happen. But it re-sizes with snapping off as well, so that's not the reason (I think, I really have no clue) Thank you for the response! :D

Ah ... and another one. Seems to be connected to the other. If I use a supernode in a flow chart. I open the supernode, change some of the output connectors in the graph inspector, then its not updating in the output node/box. Then it suddenly updates, if I disconnect and reconnect the wires. But then, if I go back to my main flow chart, where the supernode is connected, there is also no change. Have to drag the node again in the chart then its updated.

Same happens, when I change the name of the macro. Still in the chart the old name. Something wrong with my installaton ? 

+1
Fixed in Next Version

It turns out this is a Unity bug introduced in Unity 2018 and fixed in Unity 2018.2.3.

From the changelog:

  • (1047812) - Editor - Fixed issue where Unity did not calculate GUI text width correctly when GUIStyle used Word Wrap.

I had put a fix in place that prevented cropping, but resulted in weird label height. I am removing this fix for v.1.4.0f5 and users are advised to update to the latest Unity version to prevent cropping.

Unity Bug

Hi Nirgam,

This is a Unity bug that was fixed in version 2018.2.3f1. 

From the changelog:

  • (1047812) - Editor - Fixed issue where Unity did not calculate GUI text width correctly when GUIStyle used Word Wrap.

Simply update your Unity and the issue will be fixed.