+2

Unity 2018.1 Support?

Rabadash8820 2 years ago updated 2 years ago 2

Unity 2018.1 is officially out now.  I tried updating yesterday and am seeing a bunch of new warnings.  Before I go digging into them further, I thought I should ask, for the record:

Does Bolt officially support Unity 2018.1?  If not, any timeframe for when it will?

And don't let me make you feel rushed; you already blow my mind with your productivity as a single developer.  Keep up the good work!

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):

I got this Error, when importing Bolt into a new unity 2018.1 project:

Assertion failed: Cancelling DisplayDialog because it was run from a thread that is not the main thread: Opening file failed Opening file D:/Unity/HD Test/Assets/Generated/Bolt.Flow/UnitOptions.db: The process cannot access the file because it is used by another process.

But till now everything is working fine.

Looks like Unity 2018.1 will not be officially supported until Bolt 1.4, the "Live Update".  See this News post for more info.