+1
Pending Review

Can't change to non-human naming

Crystalius 3 years ago updated by William ianneci 2 years ago 6

When I change it to non-human in the settings, it always goes back to human naming after a while. 

Is it a bug?

Bolt Version:
Unity Version:
Platform(s):
Scripting Backend:
.NET Version (API Compatibility Level):
+1

I find that happens too. Try updating unit options right after. Think the unit options database actually holds that information. If it reverts too fast, do it by going through the original setup. Just skip generating inspectors and stuff and run the generation that way.

Pending Review

Hi Crystalius,

Do you have other settings reverting?

Starting from v.1.2.2, you should be able to hot-switch naming schemes without regenerating the unit database.

Make sure you press Ctrl+S after changing your settings. It'll force a save of the settings assets.

Other settings seems fine. Saving doesn't help. 

I use Bolt v.1.2.3

Going to post here since a topic about this is already here.  Seems changing from human naming <> programmer does not apply after a 'wizard setup',  So if you started of on one during the wizard, it will not save if you change it afterwards via the options>project settings. However if you REDO the full wizard, it will save.  This should prove useful to our grand Lazlo :)

This does not seem to work for me, on 1.3. It doesn't matter if I redo the setup wizard, rebuild options, saving and restarting... It just is stuck in human naming.

This project was updated from older bolt version, for what it's worth.

+1

That may be something knew Hyper, pls post that in the Bug section on the forum, ty.