0
Answered

Inspector tab for some settings not showing...

LFCamacho 2 weeks ago updated by Lazlo Bonin (Lead Developer) 2 weeks ago 1

So the whole purpose of Peek is to get rid of the Inspector tab, and access all component options right on the Scene tab, right? "Inspect game objects, components and materials with contextual toolbars without having to open the inspector." 

But,
• if you get rid of the Inspector tab and you want to add a tag or a layer to a game object, then you have to add the Inspector tab again to your layout.

• if you want to access the import settings of your sprites, you have to add the Inspector tag again.

• if you want to access the Animator transition settings, you have to add the Inspector tab again.

Am I missing something here? is there a way of doing all those things without having to momentarily re-add the inspector?

Thanks in advance!
LF

Unity Version:
2019.4.8f1
Peek Version:
1.3.0
Answered

Hi LF,

For tags and layers, you can click on the GameObject's name and/or its icon in the hierarchy to assign them. Note that due to a Unity bug, you can't create new tags and layer from Peek's contextual inspectors, but there's unfortunately nothing we can do about that.

For the import settings of sprites, same principle: click on the icon of the asset in the project window and the importer settings will show up.

Re: the animator transitions, indeed, there's no way for Peek to display that contextually AFAIK, so an inspector window would be needed.

One way a lot of users use Peek, however, is to go full screen during level editing, but then go back to their layouts with an inspector tab afterwards. Or, create multiple layouts, some of which without the inspector tab when Peek can do the job instead. I'm also working on ways to make layout switching easier in future versions, see my tweet here for a sneak peek: https://twitter.com/lazlobon/status/1312572954660741122

Best,

- Lazlo from Ludiq