0
Cannot Reproduce

The type or namespace name 'RegisterFormatterAttribute' could not be found

Ilya 2 months ago updated by Lazlo Bonin (Lead Developer) 1 month ago 12 1 duplicate
Unity Version:
Peek Version:

Duplicates 1

+1
Working on Fix

Hi Ilya,

Can you please try this workaround and let me know if it works:

  1. Select Assets/Ludiq/Ludiq.PeekCore/Dependencies/OdinSerializer/AOT/Ludiq.OdinSerializer
  2. In the inspector, check Any Platform
  3. Click Apply

Let me know!

Hello. This fix worked for me. Thanks.

Need More Information

Hi Ilya,

I'm glad the workaround worked for you!

Normally, this is an operation that should be automated by Odin during build.

I'm not sure why it didn't happen automatically in your case.

Without more information about your Unity version or setup, I can't help reproduce the issue.

If anyone else encounters this bug reliably, please comment with your version info and reproduction steps!

Hi,

Same errors on my side using the Unity / Addressables / Build / Build Player Content (iOS).
Checking Any Platform don't resolve the problem.

Best

Ludiq + Bolt + Peek up to date
Unity 2019.3.0b7

Vincent

Hi Vborcard,

Are you getting the exact same errors, or anything slightly different?

If they are the exact same, then the platform enable fix should have worked.

Please send us the log if possible!

Hi,

I modified the settings (any platform)


I get that errors :

log_with_fix.rtf

Hi Vborcard,

Please uncheck the "Exclude Platform" settings you have checked, except for "Editor". You're effectively excluding your target platform.

Hi,

Ok. It works. Checking the "any plateform" automatically check "Editor, Standalone, iOS".
Resolved to uncheck Standalone and iOs.

Many thx

+1

Hi ophilbinbriscoe,

I'm merging your issue with another similar report with a known workaround.

Cannot Reproduce

Hi everyone,

The issue here is that somehow, Odin's build automation script does not automatically kick in and set the right platforms for your current build target, which makes builds fail because the Odin attributes are not found.

This is why manually fixing the Odin DLL importer settings as indicated by the workaround above fixes it.

However, I can't get it to reproduce here at all. The Odin automation build always kicks in and sets the proper targets in the importer settings, even if I purposely uncheck/remove it beforehand.

Here's a test of me building for Peek + Android + IL2CPP + Unity 2019.3:

https://streamable.com/quhex

Unless anyone has clear reproduction steps, I can't help any more in debugging this so I'll have to mark this as cannot reproduce.

Hopefully people faced with the same issue can post repro steps, but otherwise the workaround seems to work for everyone.