0
Cannot Reproduce

PuppetMaster Components Disappear

D Marot 2 months ago updated by Lazlo Bonin (Lead Developer) 4 days ago 2
First let me say I really like the features PEEK brings to my workflow. That being said everything runs smoothly until I use two assets which I really rely on, Ootii motion controller, and Root motion's puppetmaster. So after importing a character, rigging and setting up components, everything seams to work fine.. however after playing the scene, the stopping to edit the both the Behavior Master & Puppetmaster components a couple times - they just disappear as if I never added them.. only with them. For these to play well together the components all have to be added in a certain order so its either exit without saving, and restart the scene; or rig another character from scratch.. Ive replicated this in fresh scenes, and even started blank projects; but it seams to keep happening. Is a setting off or something I can do to prevent this from happening? I really like your product but this is a pretty big factor as to whether or not I can even use it.

My specs: Win10 pro build1809
Unity 2019.2.0f1

Any help you could provide would be greatly appreciated. Thanks, Dan
Unity Version:
Peek Version:
Need More Information

Hi Dan,

Sorry you're experiencing this issue and thank you for the report. I moved it to our bug report forum.

I'm unfamiliar with PuppetMaster, but this is the first I hear of components disappearing with Peek, so I'm guessing it might have something to do with their specific component handling.

I am emailing Root Motion and linking them back to this thread. We might need to work together on this.

In the mean time, can you provide:

  • any error, warning or log in the console when the components disappear
  • a step-by-step guide to reproduce the issue from a minimal project with Peek and PuppetMaster
  • OR a video of the issue happening in your main project

Thanks!