0
Not a Bug

Issue with first time import, FuzzyOptionTree.cs and other scripts error out

zfighter 2 months ago updated 2 months ago 2

Looking forward to checking this out. When importing I get a stream of errors on multiple scripts.

I'm on Unity 2019.1.6f1 and have Bolt 1.4.4 installed

Assets\Ludiq\Ludiq.PeekCore\Editor\Interface\Fuzzy\FuzzyOptionTree.cs(125,100): error CS0433: The type 'CancellationToken' exists in both 'System.Threading, Version=1.0.2856.102, Culture=neutral, PublicKeyToken=31bf3856ad364e35' and 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'



Thanks for any help, the asset looks great!

Unity Version:
Peek Version:
Not a Bug

Hi zfighter,

First, make sure your project is using .NET 4.x Equivalent (Edit > Project Settings > Player > Scripting Runtime Version). As indicated on the Asset Store, Peek requires .NET 4.x and is incompatible with the deprecated .NET 3.x runtime.

Then, make sure you're using the .NET 4.x version of Bolt. When installing Bolt from the Asset Store, it picks the right package depending on the current .NET config of the project. If you had .NET 3.x before, then you might have a .NET 3.x version of Bolt installed.

Finally, if you installed the .NET 4.x version of Bolt but previously had a .NET 3.x version installed, you might have a leftover dependency DLL. Look for System.Threading.dll in Assets/Ludiq/Assemblies and delete it if that is the case.

Let me know if that solves your issue!

Deleting System.Threading.dll did it for me. Thank you!

BTW, Bolt is awesome. Excited for Peek!