0
Answered

How to keep pinned component inspectors open when playing

Eric Hibbs 1 week ago updated 2 days ago 2

How do I stopped pinned component windows from closing when I play and stop playing? I've got a game window pinned, but when I hit play it shows the game tab fullscreen, and when I exit live play, the pinned windows are gone.

I'm trying to tweak platformer character curves, and I bought Peek hoping I could leave those values up and tweak just those. I really hope that's possible, as I've kinda spent the money already, haha

Answered

Hi Eric,

Sorry you're experiencing this issue.

The first part of the problem is that you have your game view set to Maximize On Play, which moves away from the Scene View when entering play mode. You can disable that from the Game window toolbar, on the right.

The second part of the problem is on our end, I'm afraid. Currently the pinned tabs don't stay open when entering play mode, you have to open them again. They will be in the exact same position however!

I added an item to our roadmap to try and keep those tabs open (it's unfortunately not as simple as it sounds!). Sorry for the inconvenience in the mean time.

Hi Lazlo,

Thanks for the response. Sucks that keeping them open during gameplay is such a pain in the butt. I'm happy to help try to find solutions or whatever, as this would make Peek my favorite thing in the world (and I'm sure other developers have a similar roadblock). If that's possible, and if it might help speed up that portion of the roadmap, please let me know