0
Fixed

Scene search overrides default "Align With View" functionality

rava 2 months ago updated by Lazlo Bonin (Lead Developer) 2 months ago 6

Issue:
Unity's default Align With View [Ctrl+Shift+F] functionality, aka "translate selected gameobject to scene camera transform" doesn't work when the Scene window is focused because Peek overrides the functionality by bringing up the Hierarchy search field.

Steps to reproduce (Unity 2018 LTS):

1) Create empty GO at (0,0,0) and select it

2) Focus Scene window

3) Press [Ctrl+Shift+F]

Expected behaviour:

Unity moves GO to scene camera position

Actual behaviour:

Peek opens its hierarchy searching popup.

Additional information:

- Align With View works correctly if scene window is unfocused and GO is selected via Hierarchy.

- Pressing [Ctrl+Shift+F] after the search popup is opened will correctly perform Align With View.

Unity Version:
Peek Version:
Working on Fix

Hi Rava,

Thanks for the report and sorry you're experiencing this issue.

Are you using Mac OS X by any chance?

If so, we noticed a bug where Peek shortcuts were always mapped with "Shift" enabled, when they shouldn't. (For example, Cmd+Shift+F instead of Cmd+F). We're fixing this issue in v.1.0.1.

I'm on Windows 10, and using en-FI keyboard layout.

Still happening on 1.0.1, exact same repro.

First press of [Ctrl+Shift+F] opens up Hierarchy popup, and the second one triggers Align To View correctly.

I also noticed that if you hold [Ctrl+Shift+F] instead of pressing it quickly the Align To View functionality triggers after opening the popup, though I'm not sure if this is due to Windows' key repeat rate or Unity itself.


Here's how it looks on my end: https://gfycat.com/spiffyhauntingdingo

Play by play:

- Moving the scene camera with [RMB] to demonstrate scene is focused, release [RMB]

(At this point no inputs are pressed down.)

- Pressing [Ctrl+Shift] brings up the spawner cursor on mouse position

- Finishing the Align To View combo by pressing [F] while [Ctrl+Shift] are pressed

- Hierarchy popup opening and displaying focus cursor

- Release all keys (spawner cursor goes away, at this point no inputs are pressed down.)

- Pressing [Ctrl+Shift] brings up the spawner cursor on mouse position again

- Finishing the Align To View combo by pressing [F] properly completes the functionality, translating the selected sphere to scene camera

- Zooming out with [RMB+WASD] to demonstrate the sphere moved properly

Working on Fix

Hi Rava,

Thanks for the update. Sorry, I conflated the issue with another one at first. I was able to repro using the steps you outlined and will fix for the next version. :)