Enter the forum description here ...
+2
Fixed

Getting weird delaying Plugin container init because database is not yet initialised

Andrew Scott 2 months ago updated by Lazlo Bonin (Lead Developer) 1 month ago 6

So right through the Beta 2019.3.0 versions I never saw this message and am now seeing it, it doesn't appear all the time, but when it does Unity hangs for about 5 mins give or take.

It usually appears when I double click any area that loads up Visual Studio 2019, you can not click on anything in the Editor while it is in this tight loop. Eventually the IDE will load up and then the following warning appears in the console.

This seems to only be happening since 2019.3.0f1 was released, never saw it on previous beta versions or other versions of Unity. And unlike what the message says, this is not a new project, even thought it was created in Unity 2019.3.0, I have been working on it for a few days now.

I am not sure if this helps or not, but I have had this Editor open for the last 2 days, but I doubt that has anything to do with it. But just in case it was one of those things that happens for longer periods of use.

Delaying plugin container initialization because asset database is not yet initialized.
This can happen after a project reimport or Unity upgrade.

UnityEngine.Debug:Log(Object)
Ludiq.PeekCore.PluginContainer:.cctor() (at Assets/Ludiq/Ludiq.PeekCore/Editor/Plugins/PluginContainer.cs:25)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes(Type[])

+1
Fixed

Scripts disappear from game object toolbar after exiting play mode and reappears only in play mode

Youdaman 1 month ago updated by Lazlo Bonin (Lead Developer) 1 month ago 10

This seems to be the same bug as these:
https://support.ludiq.io/communities/41/topics/4453-inspector-shows-script-but-object-tab-doesnt
https://support.ludiq.io/communities/41/topics/4325-puppetmaster-components-disappear

However both posts didn't provide repro and while I left a comment on the first post it makes more sense to create a new post so that it's not buried.

Peek version: 1.1.5

Unity versions tested: 2018.4.13f1, 2019.2.15f1, 2019.3.0f1

Steps to reproduce

0. create a fresh project in Unity and install Peek only.

1. add either an existing script or create a new script component to a game object.

2. editor thinks for a bit and then adds script icon to game object toolbar.

3. hit play -- you can still see the script icon in the game object toolbar.

4. stop play -- script icon disappears.

5. hit play again -- icon reappears.

6. hit stop again -- icon disappears.


So it looks like the icon is added to the toolbar after you add a script but disappears on exiting play mode.

Happens with a simple cube and a new behaviour script.

Also happens if you create an object that comes with scripts already attached, e.g. MapMagic -- it creates a new MapMagic object with a MapMagic script component, and the script icon that appears after creation disappears when you exit play mode.

Same result whether in maximised or standard layout. Same result whether script created by + icon on game object toolbar in the scene tab or via the add component button in the inspector tab.

Best guess is that the refresh that happens after first adding a script which makes the icon appear, and which also makes it appear during play mode, isn't being run again after play mode finishes.

Also noticed it hides the script icon(s) for the item in the inspector when not maximised. As above, icon is there to start with, then you hit play and it's still there, but you exit play and it disappears and then reappears only in play mode.

+1
Fixed

Errors from Peek when importing NG Tools Pro Project 2019.2

WakeArray 2 months ago updated by Lazlo Bonin (Lead Developer) 1 month ago 9

Error:
TypeLoadException: Could not resolve type with token 01000085 (from typeref, class/assembly UnityEngine.AssemblyIsEditorAssembly, UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
System.MonoCustomAttrs.IsDefined (System.Reflection.ICustomAttributeProvider obj, System.Type attributeType, System.Boolean inherit) (at <599589bf4ce248909b8a14cbe4a2034e>:0)
System.Reflection.Assembly.IsDefined (System.Type attributeType, System.Boolean inherit) (at <599589bf4ce248909b8a14cbe4a2034e>:0)
System.Attribute.IsDefined (System.Reflection.Assembly element, System.Type attributeType, System.Boolean inherit) (at <599589bf4ce248909b8a14cbe4a2034e>:0)
System.Attribute.IsDefined (System.Reflection.Assembly element, System.Type attributeType) (at <599589bf4ce248909b8a14cbe4a2034e>:0)
Ludiq.PeekCore.Codebase.IsEditorAssembly (System.Reflection.Assembly assembly) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Reflection/Codebase.cs:229)
Ludiq.PeekCore.Codebase.IsEditorDependentAssembly (System.Reflection.Assembly assembly) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Reflection/Codebase.cs:247)
Ludiq.PeekCore.Codebase.IsRuntimeAssembly (System.Reflection.Assembly assembly) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Reflection/Codebase.cs:242)
Ludiq.PeekCore.Codebase..cctor () (at Assets/Ludiq/Ludiq.PeekCore/Editor/Reflection/Codebase.cs:40)
Rethrow as TypeInitializationException: The type initializer for 'Ludiq.PeekCore.Codebase' threw an exception.
Ludiq.PeekCore.PluginContainer.Initialize () (at Assets/Ludiq/Ludiq.PeekCore/Editor/Plugins/PluginContainer.cs:110)
Ludiq.PeekCore.PluginContainer+<>c.<.cctor>b__0_0 () (at Assets/Ludiq/Ludiq.PeekCore/Editor/Plugins/PluginContainer.cs:31)
UnityEditor.EditorApplication.Internal_CallDelayFunctions () (at C:/buildslave/unity/build/Editor/Mono/EditorApplication.cs:312)

This error happens every time I try to import Peek into a project with NG Tools Pro or import NG Tools Pro into a project that had Peek.

I acquired both Peek and NG Tools at the same time over the Cyber Monday sale and haven't fully had time to try either out yet, but the error prevents Peek from working in any capacity while NG Tools Pro is installed.

+1
Completed

Adding windows to Tab Order, doesn't work the way I had thought.

Andrew Scott 2 months ago updated 1 month ago 5

I had been looking at the documentation which says something like this.

Scene Tabs

Controls which window types show up as tabs in the scene view.

My thought was that I could add windows to this, as the Inspector Window and Adding Tags and Layers can't be done in Full Scene mode, I had thought adding this here would mean I have a shortcut to it. But it doesn't show up.

Am I wrong with this and if I am what chances could there be to add this feature?

+1
Under Review

Creator Snap

Jonas 4 months ago updated by ILJI 1 week ago 4

Thanks Lazlo, that did it. A nice functionality for a future version would be to have the Creator be able to snap according to snap settings. But for now, this is great!

+1
Fixed

Fuzzy finder fails on launch

Hyper 5 months ago updated by Lazlo Bonin (Lead Developer) 5 months ago 2

This happened on a simple 2019.1 project I imported Peek into. Whenever the fuzzy finder comes up (when trying to use the creator gizmo, or when creating parents / children on the hierarchy) it just fails, showing nothing at all and throwing a console error.

For what its worth the project also has Bolt 1.4.5 in it.

This is the console error:

ArgumentException: An item with the same key has already been added. Key: radio_0_on (UnityEngine.Sprite)
System.Collections.Generic.Dictionary`2[TKey,TValue].TryInsert (TKey key, TValue value, System.Collections.Generic.InsertionBehavior behavior) (at <7d97106330684add86d080ecf65bfe69>:0)
System.Collections.Generic.Dictionary`2[TKey,TValue].Add (TKey key, TValue value) (at <7d97106330684add86d080ecf65bfe69>:0)
Ludiq.Peek.CreateGameObjectOptionTree.b__4_0 () (at Assets/Ludiq/Ludiq.Peek/Editor/Creator/Fuzzy/CreateGameObjectOptionTree.cs:62)
Ludiq.PeekCore.UnityAPI+<>c__DisplayClass13_0.b__0 () (at Assets/Ludiq/Ludiq.PeekCore/Editor/Utilities/UnityAPI.cs:114)
--- End of stack trace from previous location where exception was thrown ---
System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () (at <7d97106330684add86d080ecf65bfe69>:0)
Ludiq.PeekCore.UnityAPI.Await (System.Action action, System.Nullable`1[T] timeout) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Utilities/UnityAPI.cs:138)
Ludiq.PeekCore.UnityAPI.Await (System.Action action) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Utilities/UnityAPI.cs:91)
Ludiq.Peek.CreateGameObjectOptionTree.Prewarm () (at Assets/Ludiq/Ludiq.Peek/Editor/Creator/Fuzzy/CreateGameObjectOptionTree.cs:27)
Ludiq.PeekCore.FuzzyWindow+<>c__DisplayClass18_0.b__0 () (at Assets/Ludiq/Ludiq.PeekCore/Editor/Interface/Fuzzy/FuzzyWindow.cs:360)
Ludiq.PeekCore.FuzzyWindow.RunTaskSynchronous (System.Action task) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Interface/Fuzzy/FuzzyWindow.cs:1274)
UnityEngine.Debug:LogException(Exception)
Ludiq.PeekCore.FuzzyWindow:RunTaskSynchronous(Action) (at Assets/Ludiq/Ludiq.PeekCore/Editor/Interface/Fuzzy/FuzzyWindow.cs:1279)
Ludiq.PeekCore.FuzzyWindow:Work() (at Assets/Ludiq/Ludiq.PeekCore/Editor/Interface/Fuzzy/FuzzyWindow.cs:1308)
System.Threading.ThreadHelper:ThreadStart()

+1
Fixed

Editor Crashes Megathread (Send us your logs!)

Lazlo Bonin (Lead Developer) 6 months ago updated 1 month ago 35

Some users have been reporting some instability / crashes. These are full editor crashes that bring up the error reporter, not console errors.

Unfortunately, we don't have enough information to debug. 

We ask users to send us the debug files that Unity generates for the editor when crashing:

  • Editor.log
  • Error.log
  • crash.dmp

They can be found here:

macOS~/Library/Logs/Unity/
WindowsC:\Users\username\AppData\Local\Unity\Editor\

Sometimes, inside the logs, there seems to be no link to Peek or Ludiq at all. However, we're pretty sure something in our plugin is causing it. In those cases, if you see nothing Peek/Ludiq related, please submit the bug report to Unity. This is the best way for them to investigate and debug the internals of what's happening. Also, please link back to your Unity report here so we can follow up and look for consistency across them.

Thank you and sorry for the inconvenience!

0
Fixed (Unreleased)

Bug in MathUtility Multiply, Divide, Modulo methods

GJ Roelofs 4 days ago updated by Lazlo Bonin (Lead Developer) 20 hours ago 3

In these methods the `y` parameter is used for the RHS argument where the `x` argument should be used.

See below:

0
Need More Information

Peek force unity to crash + Cannot select GO with 2d Colliders and without any renderer on it by RMC

Goodee 1 week ago updated by Lazlo Bonin (Lead Developer) 1 week ago 1

sSByHCiH3p.gif
1) Peek force unity to crash, when i hover element, which are prefab i edit in this time(Compare names of prefab and last hovered element):


Logs:
Editor.log
error.log

2) I cant select GO with 2d Colliders and without any renderer on it by Right Mouse Click:
LoUk9tGflS.gif

0
Under Review

Suggestions from a new peek user

Mark McCorkle 2 weeks ago updated by Lazlo Bonin (Lead Developer) 20 hours ago 3

Below are some my observations and little nibbles I'd love to see considered for future Peek versions.  This is copied from my post on my asset store review.


Feature Requests:

* a red dot with number notification indicator when something under a drawer need my attention (e.g. when there is an error posted to Console or Game window has become active by isn't yet in view)

* when I'm holding down right click in scene view for free look (fly mode) should ignore the "space" hotkey so that it can be used to fly up.

* Figure out a better workflow for when I am in full screen scene view for when I hit ctrl-p. Currently game view doesn't appear.

* add a "workflow wizard" which could include a Unity layout + peek configs + hokeys into something I can export from this project and import easily into the next.

* add Ludiq folders to .collabignore (or .gitignore, etc) on the install of peek. I didn't want them in my repo, and I think I'd be breaking the per seat purchase rules if I was collaborating with anyone on this project. Make it easy for me to do the right thing.

* don't stack Custom Scripts into one button by default -- instead have the wizard offer me the option to put icons on them (or walk me through that in project view at least).

-- if no user icon -- put a "Ps" (adobe style) icon for the name of the script (e.g. MouseManager would be "Mm", and something like ReallyLongNamedScript would be "Rs").

* along with that, add fuzzy search for emoji to the list of things I can assign as icons

* filling empty reference boxes in scripts is not intuitive (drag and drop feels backwards to me) and having to sticky an inspector window feels counter to the Peek design. Perhaps an option to replaces the "dot circle" default Unity search dialog with the same fuzzy search I use everywhere else?



Little things I'd expect to be able to do with keyboard which don't work:

* pressing space when an object is selected brings up the secondary bar but in fuzzy search mode -- so the alt-1, 2, 3, etc keys don't work (though they show up if you hot alt)

* from the same if you are in the "add component" dialog, you can't go back to any of the previous views via their alt-# hotkeys

* when viewing a component property, if I press space, it opens the property as a distinct popup window (yay!) but in many other places (like opening project, hierarchy, console, etc from the main bar) pressing space does not do the same behavior.

* pressing escape will close a secondary bar menu item, but not the primary one.

* arrow keys when a button is selected could select the neighboring buttons