0
Fixed

AreaClock2D (timeScale=0) glitches quick physics objects

shottogan 3 years ago updated 3 years ago 5

If a block at full falling speed passes into an AreaClock2D with timeScale = 0 (or paused), the following takes place:

However, I found that setting the timeScale instead to 0.002 behaves better:


0.002 is the closest I can set it to 0 to avoid this.
<= 0.001 causes objects to lose their horizontal velocity after the AC is disabled.

(Note that before the AC is disabled I LerpTimeScale() it back to 1)


Thanks!!

Chronos Version:
2.4.7
Unity Version:
5.5.2f1
GOOD, I'M SATISFIED
Satisfaction mark by shottogan 3 years ago

(Let me know if higher FPS GIFs and hiding the reversed blocks would help)

Pending Review

Could you please send me a zip of this simple scene (without the Chronos folder)?

Thanks for sending me the zip.

Upon review, this seems to be linked to: http://support.ludiq.io/topics/48-pause-bugglitches-on-tutorial/

I'll be attempting a fix for v.2.4.8.

Good luck, thank you!