0
Unity Bug

Particle Systems stutter

lars.pfeiffer 2 years ago updated by Lazlo Bonin (Lead Developer) 2 years ago 3 2 duplicates

Any particle system I add to any scene are starting to stutter after a short amount of time. It seems that the time inside the particle system simulation gets reset, as the individual particles are jumping back to a point they have been before in time.
If you rewind the timescale this stuttering behavior is played exactly as it was recorded (but obviously played backwards ;) )

This behavior is only true for rewindable particle systems, non-rewindable are not affected.

Reproduction:

- Start new project, add Chronos to it
- Open new scene
- Add timekeeper
- add particle system
- add timeline component to particle system and set clock global root clock



Chronos Version:
2.4.12
Unity Version:
2017.4.0f1

Duplicates 2

+1
Unity Bug

Hi Lars,

Sorry for the late reply on this. This is a Unity bug introduced in newer versions. I reported it here:

https://fogbugz.unity3d.com/default.asp?854431_5mmt5ltn2q6nuseh

And it's been merged with this issue:

https://issuetracker.unity3d.com/issues/particle-system-simulate-issues

But the Unity developers don't seem very keen to fix it. I suggest adding your vote or commenting on the issue to move it further along.

Pending Review

Hi Kemikalx,

Unfortunately, this is a Unity bug that has been reported many times, confirmed, but never fixed by Unity.

I'm merging your thread with the other report.

Pending Review

Hi Mikhail,

Unfortunately, this is a Unity bug that has been reported many times, confirmed, but never fixed by Unity.

I'm merging your thread with the other report.