Let's start by getting our project ready.

1. Create a new 2D project

Create a new 2D project called BoltPlatformerTutorial.


2. Download and install Bolt

Open Window > Asset Store and search for Bolt. Once purchased and downloaded, click Import, then Import again in the new dialog:

After the import, the setup dialog will show. Follow the instructions on screen to install Bolt. For more information, see the manual:

Manual: Installation

For this tutorial, we will be using Human Naming.

3. Change the tags and layers settings

Open Edit > Project Settings > Tags & Layers and add new layers and tags so that your configuration is exactly like the following screenshot:


4. Change the collision matrix

Open Edit > Project Settings > Physics 2D and make your collision matrix match this one:

5. Download and import the tutorial assets

Click the link below to download the tutorial assets package, then import it in your project:

BoltPlatformerTutorial.unitypackage

6. Add the tutorial scenes to the build settings

Open File > Build Settings... and drag & drop all the scenes inside the Scenes folder:

5. Open the first scene

Open the level 1 scene located at Scenes / Level1.

6. Setup your window layout

Finally, we'll open all the Bolt windows and setup a comfortable layout to work in. This part is personal, of course, but we have a few recommendations from our experience working with Bolt. 

Start by opening all the Graph, Graph Inspector and Variables windows from the Window menu:



If you have a single monitor, here is the layout we recommend. Note that on Windows, we moved our task bar to the side of the screen to get even more vertical space.


If you have dual monitors, we recommend using the second monitor entirely for Bolt graph editing, like so: 


Introduction Character Controller

This article was helpful for 2 people. Is this article helpful for you?